Troubleshooting Deployment Errors
Deploying Appsmith is typically a smooth process, but sometimes you may encounter errors that prevent you from successfully setting up your instance. This guide walks through common deployment-related errors and provides strategies for troubleshooting them.
Pre-deployment checklist
Before delving into specific errors, it's essential to ensure that the pre-deployment conditions are met:
- Confirm that the target server meets the minimum hardware requirements.
- Verify that you have the necessary permissions to install and configure Appsmith on the server.
- Ensure that all required ports (for example, 80 and 443 for web traffic) are open and not blocked by a firewall.
Port conflicts
After installation, Appsmith services might fail to start due to port not being available.
Error message
Cause
The error occurs when the required ports 80
and 443
are not available for Appsmith to use due to other processes using them.
Solution
To address this issue, you have the following options:
- Stop all processes on ports
80
and443
and start again. This ensures that the processes using the ports may free the ports and Appsmith can use it. This only helps if there were processes which were using ports but are no longer running on those ports. - If stopping processes on these ports is not viable, or there are other processes which continue to run on these ports then edit the
docker-compose.yml
file to assign different ports to Appsmith and restart the instance.
Configuration problems
After installation, Appsmith services might fail to start due to some configuration problems.
Error message
Cause
The error occurs when the Appsmith instance cannot access MongoDB data due to an encryption mismatch. This can happen under two circumstances:
- Installing Appsmith in a directory with an existing Appsmith installation, causing issues due to mismatch in encryption settings.
- Restoring an Appsmith database backup with encryption parameters different from those configured in the Appsmith instance.
Solution
To resolve the error, you may choose one of the below options:
- If you want to overwrite the previous Appsmith installation, delete the
/stacks
folder from the installation directory, and re-run the Docker command. - If you want to keep the previous Appsmith installation, create a new installation directory and follow the installation instructions.
- If you want to use the Appsmith installation after restoring the data, go to the
docker.env
file and update the encryption password (APPSMITH_ENCRYPTION_PASSWORD
)and encryption salt (APPSMITH_ENCRYPTION_SALT
) with the values you copied during the backup process. For more information, see Backup Database.